ASR(4FREEBSD) - man page online | special files
Driver for Adaptec I2O based SCSI/ATA host bus adapters.
July 14, 2004
ASR(4) BSD Kernel Interfaces Manual ASR(4)
NAMEasr — driver for Adaptec I2O based SCSI/ATA host bus adapters
DESCRIPTIONThe Adaptec asr driver provides access to disks and disk arrays controlled by I2O based host bus adapters and SmartRAID SCSI RAID adapters through the standard SCSI disk da(4) inter‐ face. The supported adapters provide 64 bit PCI, Compact PCI, Zero Channel PCI, and up to four channels of Ultra2, Ultra 160, or Ultra320 SCSI, or two channels of 1GB Fibre. All support RAID-0, RAID-1, RAID-10, RAID-5 and RAID-50 arrays. All SCSI target types are supported. For the ATA based controllers, one IDE drive per channel is supported. Hot-swapping of IDE drives is not supported at this time. All host bus adapters must be configured before they can be used with any operating system. Please contact Adaptec directly to obtain the latest information on configuration utilities for the adapters. Currently there are both a Motif based GUI configuration utility and a CLI based configuration utility available from the Adaptec Web site. The cards and arrays can also be configured via the BIOS based configuration tool (SMOR).
HARDWAREThe adapters currently supported by the asr driver include the following: · Adaptec Zero-Channel SCSI RAID 2000S, 2005S, 2010S, 2015S · Adaptec SCSI RAID 2100S, 2110S · Adaptec ATA-100 RAID 2400A · Adaptec SCSI RAID 3200S, 3210S · Adaptec SCSI RAID 3400S, 3410S · Adaptec SmartRAID PM1554 · Adaptec SmartRAID PM1564 · Adaptec SmartRAID PM2554 · Adaptec SmartRAID PM2564 · Adaptec SmartRAID PM2664 · Adaptec SmartRAID PM2754 · Adaptec SmartRAID PM2865 · Adaptec SmartRAID PM3754 · Adaptec SmartRAID PM3755U2B / SmartRAID V Millennium · Adaptec SmartRAID PM3757 · DEC KZPCC-AC (LVD 1-ch, 4MB or 16MB cache), DEC KZPCC-CE (LVD 3-ch, 64MB cache), DEC KZPCC-XC (LVD 1-ch, 16MB cache), DEC KZPCC-XE (LVD 3-ch, 64MB cache) -- rebadged Smar‐ tRAID V Millennium
FILES/dev/asr* Adaptec SCSI RAID control nodes
NOTESThe ATA based controllers present their devices as SCSI-like devices via CAM. For IDE drives attached to these cards, a subset of standard SCSI commands and mode pages are under‐ stood via translation performed in the card's firmware.
HISTORYThe asr (Adaptec SCSI RAID) driver first appeared as the dpti2o driver under BSDi BSD/OS 3.2, then under FreeBSD 2.2.8 and was ported over to the CAM layer represented in 4.0.
BSD July 14, 2004 BSD
AUTHORSThe asr driver was kindly donated by Adaptec and is maintained by Mark Salyzyn <@adaptec.com>. This manual page was written by Mark Salyzyn and fixed up by Jeroen Ruigrok van der Werven <@FreeBSD.org>.
|This manual||Reference||Other manuals|