HV_ATA_PCI_DISENGAGE(4FREEBSD) - man page online | special files
Hyper-V ATA PCI Disengage driver.
September 10, 2013
HYPER-V(4) BSD Kernel Interfaces Manual HYPER-V(4)
NAMEhv_ata_pci_disengage — Hyper-V ATA PCI Disengage driver
SYNOPSISTo compile this driver into the kernel, place the following lines in the system kernel con‐ figuration file: device hyperv
DESCRIPTIONThe hv_ata_pci_disengage driver prevents the native FreeBSD ATA driver from loading in the presence of Hyper-V. FreeBSD guests running on Hyper-V can take advantage of the Hyper-V Storage Virtual Consumer (hv_storvsc(4)) for using their IDE devices. Since the ATA driver serves IDE devices as well, there is a chance that the ATA driver may interfere with the operations of hv_storvsc(4). The hv_ata_pci_disengage driver avoids conflicts between the ATA driver and hv_storvsc(4) by disabling the ATA driver when the FreeBSD guest is booting. A side effect of disabling the ATA driver is that CDROM may become inoperational on FreeBSD guest partitions. If CDROM access is a must then users may use "set hw.ata.disk_enable=1" at boot time to prevent the ATA driver from being disabled.
SEE ALSOhv_vmbus(4), hv_utils(4), hv_netvsc(4), hv_storvsc(4)
HISTORYSupport for hv_ata_pci_disengage first appeared in FreeBSD 10.0. The driver was developed through a joint effort between Citrix Incorporated, Microsoft Corporation, and Network Appliance Incorporated.
BSD September 10, 2013 BSD
AUTHORSFreeBSD support for hv_ata_pci_disengage was first added by Microsoft BSD Integration Services Team <@microsoft.com>.
|This manual||Reference||Other manuals|
|hv_ata_pci_disengage(4freebsd)||referred by||hv_kvp(4freebsd) | hv_netvsc(4freebsd) | hv_storvsc(4freebsd) | hv_utils(4freebsd) | hv_vmbus(4freebsd)|
|refer to||hv_netvsc(4freebsd) | hv_storvsc(4freebsd) | hv_utils(4freebsd) | hv_vmbus(4freebsd)|