NVE(4FREEBSD) - man page online | special files
NVIDIA nForce MCP Networking Adapter device driver.
February 13, 2014
NVE(4) BSD Kernel Interfaces Manual NVE(4)
NAMEnve — NVIDIA nForce MCP Networking Adapter device driver
SYNOPSISWarning: This driver is deprecated and will not be available in FreeBSD 11.0 and later. Please consider using the nfe(4) driver instead. To compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device nve Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_nve_load="YES"
DESCRIPTIONThe nve driver provides support for the NVIDIA nForce MCP and nForce2 MCP2 networking adapter that is embedded in the southbridge of most nForce and nForce2 motherboards. This driver is a reimplementation of the NVIDIA supported Linux nvnet driver and uses the same closed source API library to access the underlying hardware. There is currently no programming documentation available for this device, and therefore little is known about the internal architecture of the MAC engine itself. The nve driver supports the following media types: autoselect Enable autoselection of the media type and options. 10baseT/UTP Set 10Mbps operation. 100baseTX Set 100Mbps (Fast Ethernet) operation. 1000baseTX Set 1000Mbps (Gigabit Ethernet) operation. The nve driver supports the following media options: full-duplex Set full duplex operation. For more information on configuring this device, see ifconfig(8).
HARDWAREThe nve driver supports the NVIDIA MCP onboard adapters of mainboards with the following chipsets: · nForce · nForce2 · nForce3 · nForce4
DIAGNOSTICSnve%d: couldn't map memory A fatal initialization error has occurred. nve%d: couldn't map interrupt A fatal initialization error has occurred. nve%d: failed to allocate memory There are not enough mbufs available for allocation. nve%d: device timeout The device has stopped responding to the network, or there is a prob‐ lem with the network connection (cable).
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), nfe(4), ng_ether(4), rgephy(4), ifconfig(8)
HISTORYThe nve driver first appeared in FreeBSD 6.0.
AUTHORSThe nve driver was written by Quinton Dolan <@onthenet.com.au> and David E. O'Brien <@FreeBSD.org>.
BSD February 13, 2014 BSD
BUGSThere are reports that when the card is in auto select mode, ifconfig output reports a 10baseT/UTP output while the LEDs and bandwidth show that the card is actually in 100baseTX mode.
|This manual||Reference||Other manuals|
|nve(4freebsd)||referred by||ALTQ(4freebsd) | altq(4freebsd) | if_nve(4freebsd) | if_vlan(4freebsd) | miibus(4freebsd) | vlan(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | nfe(4freebsd) | ng_ether(4freebsd) | rgephy(4freebsd)|