BUS_RESCAN(9FREEBSD) - Linux man page online | System kernel interfaces
Rescan a bus checking for devices that have been added or removed.
April 27, 2016
BUS_RESCAN(9) BSD Kernel Developer's Manual BUS_RESCAN(9)
BSD April 27, 2016 BSD
NAMEBUS_RESCAN — rescan a bus checking for devices that have been added or removed
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> void BUS_RESCAN(device_t dev);
DESCRIPTIONThe BUS_RESCAN() method is called to request a rescan of the child devices on a bus device. The method should add any devices that have been added since the previous scan and remove devices that have been removed. This method is not required to re-examine existing devices to determine if their properties have changed. This method is also not required to propa‐ gate the rescan request to child devices.
|This manual||Reference||Other manuals|