BUS_WRITE_IVAR(9FREEBSD) - Linux man page online | System kernel interfaces
Manipulate bus-specific device instance variables.
June 16, 1998
BUS_READ_IVAR(9) BSD Kernel Developer's Manual BUS_READ_IVAR(9)
BSD June 16, 1998 BSD
NAMEBUS_READ_IVAR, BUS_WRITE_IVAR — manipulate bus-specific device instance variables
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int BUS_READ_IVAR(device_t dev, device_t child, int index, uintptr_t *result); int BUS_WRITE_IVAR(device_t dev, device_t child, int index, uintptr_t value);
DESCRIPTIONThese two methods manage a bus specific set of instance variables of a child device. The intention is that each different type of bus defines a set of appropriate instance variables (such as ports and irqs for ISA bus etc.) This information could be given to the child device as a struct but that makes it hard for a bus to add or remove variables without forcing an edit and recompile for all drivers which may not be possible for vendor supplied binary drivers.
RETURN VALUESZero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevice(9), driver(9)
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|refer to||BUS_READ_IVAR(9freebsd) | device(9freebsd) | driver(9freebsd)|