VFS_FHTOVP(9FREEBSD) - man page online | system kernel interfaces
Turn an NFS filehandle into a vnode.
January 4, 2010
VFS_FHTOVP(9) BSD Kernel Developer's Manual VFS_FHTOVP(9)
NAMEVFS_FHTOVP — turn an NFS filehandle into a vnode
SYNOPSIS#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp);
DESCRIPTIONThe VFS_FHTOVP() macro is used by the NFS server to turn an NFS filehandle into a vnode. The arguments it expects are: mp The file system. fhp The filehandle to convert. vpp Return parameter for the new locked vnode. The contents of the filehandle are defined by the file system and are not examined by any other part of the system. It should contain enough information to uniquely identify a file within the file system as well as noticing when a file has been removed and the file system resources have been reused for a new file. For instance, UFS file system stores the inode number and inode generation counter in its filehandle. A call to VFS_FHTOVP() should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client.
RETURN VALUESThe locked vnode for the file will be returned in *vpp.
SEE ALSOVFS(9), VFS_CHECKEXP(9), VOP_VPTOFH(9), vnode(9)
BSD January 4, 2010 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|VFS_FHTOVP(9freebsd)||referred by||VFS(9freebsd) | VFS_CHECKEXP(9freebsd) | VOP_VPTOFH(9freebsd)|
|refer to||VFS(9freebsd) | VFS_CHECKEXP(9freebsd) | vnode(9freebsd) | VOP_VPTOFH(9freebsd)|