VFS_MOUNT(9FREEBSD) - man page online | system kernel interfaces
Mount a file system.
May 23, 2009
VFS_MOUNT(9) BSD Kernel Developer's Manual VFS_MOUNT(9)
NAMEVFS_MOUNT — mount a file system
SYNOPSIS#include <sys/param.h> #include <sys/mount.h> #include <sys/vnode.h> int VFS_MOUNT(struct mount *mp);
DESCRIPTIONThe VFS_MOUNT() macro mounts a file system into the system's namespace or updates the attributes of an already mounted file system. The arguments it expects are: mp Structure representing the file system. The VFS_MOUNT() macro is called both to mount new file systems and to change the attributes of an existing file system. If the MNT_UPDATE flag is set in mp->mnt_flag then the file system should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only file system to read-write. It is also used by mountd(8) to update the NFS export information for the file system. If the MNT_UPDATE flag is not specified, then this is a newly mounted file system. The file system code should allocate and initialize any private data needed to represent the file system (it can use the mp->mnt_data field to store this information).
SEE ALSOVFS(9), vnode(9)
BSD May 23, 2009 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|VFS_MOUNT(9freebsd)||referred by||free_mntarg(9freebsd) | kernel_mount(9freebsd) | kernel_vmount(9freebsd) | mount_arg(9freebsd) | mount_argb(9freebsd) | mount_argf(9freebsd) | mount_argsu(9freebsd) | VFS(9freebsd)|
|refer to||mountd(8) | VFS(9freebsd) | vnode(9freebsd)|