VOP_FSYNC(9FREEBSD) - man page online | system kernel interfaces
Flush file system buffers for a file.
July 24, 1996
VOP_FSYNC(9) BSD Kernel Developer's Manual VOP_FSYNC(9)
NAMEVOP_FSYNC — flush file system buffers for a file
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> int VOP_FSYNC(struct vnode *vp, int waitfor, struct thread *td);
DESCRIPTIONThis call flushes any dirty file system buffers for the file. It is used to implement the sync(2) and fsync(2) system calls. Its arguments are: vp The vnode of the file. waitfor Whether the function should wait for I/O to complete. Possible values are: MNT_WAIT Synchronously wait for I/O to complete. MNT_NOWAIT Start all I/O, but do not wait for it. MNT_LAZY Push data not written by file system syncer. td The calling thread.
LOCKSThe file should be locked on entry.
RETURN VALUESZero is returned if the call is successful, otherwise an appropriate error code is returned.
ERRORS[ENOSPC] The file system is full. [EDQUOT] Quota exceeded.
BSD July 24, 1996 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|VOP_FSYNC(9freebsd)||referred by||VFS_SYNC(9freebsd) | vinvalbuf(9freebsd) | vnode(9freebsd)|
|refer to||fsync(2) | sync(2) | vnode(9freebsd)|