VOP_GETACL(9FREEBSD) - man page online | system kernel interfaces
Retrieve access control list for a vnode.
December 23, 1999
VOP_GETACL(9) BSD Kernel Developer's Manual VOP_GETACL(9)
NAMEVOP_GETACL — retrieve access control list for a vnode
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> #include <sys/acl.h> int VOP_GETACL(struct vnode *vp, acl_type_t type, struct acl *aclp, struct ucred *cred, struct thread *td);
DESCRIPTIONThis vnode call may be used to retrieve the access control list (ACL) from a file or direc‐ tory. Its arguments are: vp The vnode of the file or directory. type The type of ACL to retrieve. aclp A pointer to an ACL structure to receive the ACL data. cred The user credentials to use in authorizing the request. td The thread requesting the ACL. The cred pointer may be NULL to indicate that access control checks are not to be performed, if possible. This cred setting might be used to allow the kernel to authorize ACL retrieval that the active process might not be permitted to do. The vnode ACL interface defines the syntax, and not semantics, of file and directory ACL interfaces. More information about ACL management in kernel may be found in acl(9).
LOCKSThe vnode will be locked on entry and should remain locked on return.
RETURN VALUESIf the aclp pointer will point to a valid ACL, then zero is returned. Otherwise, an appro‐ priate error code is returned.
ERRORS[EINVAL] The ACL type passed is invalid for this vnode. [EACCES] The caller does not have the appropriate privilege. [ENOMEM] Sufficient memory is not available to fulfill the request. [EOPNOTSUPP] The file system does not support VOP_GETACL().
SEE ALSOacl(9), vnode(9), VOP_ACLCHECK(9), VOP_SETACL(9)
BSD December 23, 1999 BSD
AUTHORSThis manual page was written by Robert Watson.
|This manual||Reference||Other manuals|
|VOP_GETACL(9freebsd)||referred by||acl(9freebsd) | vnode(9freebsd) | VOP_ACLCHECK(9freebsd) | VOP_SETACL(9freebsd)|
|refer to||acl(9freebsd) | vnode(9freebsd) | VOP_ACLCHECK(9freebsd) | VOP_SETACL(9freebsd)|