VOP_IOCTL(9FREEBSD) - man page online | system kernel interfaces
Device specific control.
July 24, 1996
VOP_IOCTL(9) BSD Kernel Developer's Manual VOP_IOCTL(9)
NAMEVOP_IOCTL — device specific control
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> int VOP_IOCTL(struct vnode *vp, u_long command, caddr_t data, int fflag, struct ucred *cred, struct thread *td);
DESCRIPTIONManipulate a file in device dependent ways. Its arguments are: vp The vnode of the file (normally representing a device). command The device specific operation to perform. data Extra data for the specified operation. fflag Some flags ??? cred The caller's credentials. td The calling thread. Most file systems do not implement this entry point.
LOCKSThe file should not be locked on entry.
RETURN VALUESIf successful, zero is returned, otherwise an appropriate error code. If the ioctl is not recognized or not handled, ENOTTY should be returned.
BSD July 24, 1996 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|