VOP_REVOKE(9FREEBSD) - man page online | system kernel interfaces
Revoke access to a device and its aliases.
February 5, 2002
VOP_REVOKE(9) BSD Kernel Developer's Manual VOP_REVOKE(9)
NAMEVOP_REVOKE — revoke access to a device and its aliases
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> int VOP_REVOKE(struct vnode *vp, int flags);
DESCRIPTIONVOP_REVOKE() will administratively revoke access to the device specified by vp, as well as any aliases created via make_dev_alias(9). Further file operations on any of these devices by processes which have them open will nominally fail. The flags must be set to REVOKEALL to signify that all access will be revoked; any other value is invalid.
LOCKSThe vp must be unlocked on entry, and will remain unlocked upon return.
SEE ALSOmake_dev_alias(9), vnode(9)
BSD February 5, 2002 BSD
AUTHORSThis manual page was written by Brian Fundakowski Feldman.
|This manual||Reference||Other manuals|
|refer to||make_dev_alias(9freebsd) | vnode(9freebsd)|