VOP_VPTOCNP(9FREEBSD) - man page online | system kernel interfaces
Translate a vnode to its component name.
November 19, 2011
VOP_VPTOCNP(9) BSD Kernel Developer's Manual VOP_VPTOCNP(9)
NAMEVOP_VPTOCNP — translate a vnode to its component name
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> int VOP_VPTOCNP(struct vnode *vp, struct vnode **dvp, char *buf, int *buflen);
DESCRIPTIONThis translates a vnode into its component name, and writes that name to the head of the buffer specified by buf. vp The vnode to translate. dvp The vnode of the parent directory of vp. buf The buffer into which to prepend the component name. buflen The remaining size of the buffer. The default implementation of VOP_VPTOCNP scans through vp's parent directory looking for a dirent with a matching file number. If vp is not a directory, then VOP_VPTOCNP returns ENOENT.
LOCKSThe vnode should be locked on entry and will still be locked on exit. The parent directory vnode will be unlocked on a successful exit. However, it will have its use count incre‐ mented.
RETURN VALUESZero is returned on success, otherwise an error code is returned.
ERRORS[ENOMEM] The buffer was not large enough to hold the vnode's component name. [ENOENT] The vnode was not found on the file system.
SEE ALSOVOP_LOOKUP(9), vnode(9)
NOTESThis interface is a work in progress.
HISTORYThe function VOP_VPTOCNP appeared in FreeBSD 8.0.
BSD November 19, 2011 BSD
AUTHORSThis manual page was written by Joe Marcus Clarke.
|This manual||Reference||Other manuals|
|refer to||vnode(9freebsd) | VOP_LOOKUP(9freebsd)|