ACPI_SONY(4FREEBSD) - Linux man page online | Special files
ACPI notebook controller driver for Sony laptops.
February 8, 2010
ACPI_SONY(4) BSD Kernel Interfaces Manual ACPI_SONY(4)
BSD February 8, 2010 BSD
NAMEacpi_sony — ACPI notebook controller driver for Sony laptops
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device acpi_sony Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): acpi_sony_load="YES"
DESCRIPTIONThe acpi_sony driver provides support for the notebook controller in Sony laptops. Note that not all features will work on all laptop models.
SYSCTLSThe following sysctl nodes are currently implemented: dev.acpi_sony.0.brightness Current brightness level of the display. dev.acpi_sony.0.brightness_default Default brightness level of the display (survives reboot). dev.acpi_sony.0.contrast Current contrast level of the display. dev.acpi_sony.0.bass_gain Enable or disable the Bass Gain feature. dev.acpi_sony.0.cdp Turns the CD power on or off. dev.acpi_sony.0.azp Turns the audio power on or off. dev.acpi_sony.0.lnp Turns the wired network interface power on or off.
SEE ALSOacpi(4), sysctl(8)
HISTORYThe acpi_sony driver first appeared in FreeBSD 6.0.
AUTHORSThe acpi_sony driver was written by Takanori Watanabe <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||acpi(4freebsd) | sysctl(8)|