AESNI(4FREEBSD) - man page online | special files
Driver for the AES accelerator on Intel CPUs.
September 6, 2010
AESNI(4) BSD Kernel Interfaces Manual AESNI(4)
NAMEaesni — driver for the AES accelerator on Intel CPUs
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device crypto device aesni Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): aesni_load="YES"
DESCRIPTIONStarting with some models of Core i5/i7, Intel processors implement a new set of instruc‐ tions called AESNI. The set of six instructions accelerates the calculation of the key schedule for key lengths of 128, 192, and 256 of the Advanced Encryption Standard (AES) sym‐ metric cipher, and provides a hardware implementation of the regular and the last encryption and decryption rounds. The processor capability is reported as AESNI in the Features2 line at boot. The aesni driver does not attach on systems that lack the required CPU capability. The aesni driver registers itself to accelerate AES operations for crypto(4). Besides speed, the advantage of using the aesni driver is that the AESNI operation is data-indepen‐ dent, thus eliminating some attack vectors based on measuring cache use and timings typi‐ cally present in table-driven implementations.
SEE ALSOcrypt(3), crypto(4), intro(4), ipsec(4), padlock(4), random(4), crypto(9)
HISTORYThe aesni driver first appeared in FreeBSD 9.0.
BSD September 6, 2010 BSD
AUTHORSThe aesni driver was written by Konstantin Belousov <@FreeBSD.org>. The key schedule calculation code was adopted from the sample provided by Intel and used in the analogous OpenBSD driver.
|This manual||Reference||Other manuals|
|aesni(4freebsd)||referred by||crypto(4freebsd) | cryptodev(4freebsd)|
|refer to||crypt(3) | crypto(4freebsd) | crypto(9freebsd) | intro(4) | ipsec(4freebsd) | padlock(4freebsd) | random(4)|