APSFILTERRC(5) - man page online | file formats
Configuration file for magic print filter.
April 08, 2000
APSFILTERRC(5) BSD File Formats Manual APSFILTERRC(5)
NAME apsfilterrc — configuration file for magic print filter SYNOPSIS apsfillterrc DESCRIPTION Apsfilterrc is a configuration file for printers controlled by the apsfilter(1) magic fil‐ ter. Every apsfilter printer in printcap(5) has an apsfilterrc file of its own. There is one global apsfilterrc file that controls print characteristics for all printer. The printer-specific apsfilterrc files have preference over the global one. Reasons for using an apsfilterrc file are if it turns out, that you have to type in some commandline options too often or if an application is unable to parameterize the print com‐ mand, so that you have to hardcode the print characteristic for such dumb applications. An enhancement to this concept are user-specific config files, that have preference over the global and the printer-specific config file. This allows configuration of print characteris‐ tics on a per-user basis. You should make use of user-specific config files instead of using the deprecated USE_USER_CODE variable, which compromises system security and is only an option on a single- user machine, see below. Capabilities QUALITY Select print quality (draft, lo|low, med|medium, hi|high, photo). SWEEP Print uni- or bidirectional (uni, bi). MEDIA Select paper type (plain, coated, glossy, premium, trans). COLOR Select color mode (color|colour, gray|grey, mono). METHOD Choose apsfilters method of data processing (auto, ascii, raw). Automatic file type recognition and automatic conversion to Postscript is apsfilters default processing method. If you want to print mostly files `as is', you can set the default to 'raw', this disables any kind of file type recogni‐ tion and conversion. If you want to print mostly everything as ASCII text, then you can set this option to 'ascii'. PAPERSIZE Set the default paper size (a3, a4, legal, ledger, tabloid). ASCII_FILTER Text file filter to use, when printing ASCII documents (a2ps, mpage, enscript, recode). PAPERTRAY Paper feed tray number (tray0...tray9). PRETTY_PRINTING a2ps highlight level for pretty-printing when using a2ps or enscript as ascii filter (0, 1, 2). See also ASCII_FILTER. ASCII_HEADER Whether you want headers in your text prints when using a2ps, mpage or enscript as ascii filter (header, noheader). ASCII_BORDER Whether you want borders in your text prints when using a2ps, mpage or enscript as ascii filter (border, noborder). PS_NUP|ASCII_PPS Pages per sheet (1pps, 2pps, 4pps, 8pps). LANDSCAPE|ASCII_LANDSCAPE Paper orientation (landscape, portrait). PS_BOOK Output pages in "book" format, implies commandline options "2pps,duplex,shortbind". Related options: PS_NUP, ASCII_PPS, DUPLEX, BIND‐ ING. DUPLEX Whether to use duplex mode or not (duplex, simplex). BINDING Paper binding edge (shortbind, longbind). COPIES Number of copies (copies=N). USE_USER_CODE Enabling this option is a big potential security hole !!! If you don't understand this, DO NOT USE IT. It makes user manageable apsfilterrc files possible which will be sourced (included/executed) during runtime of a printjob under the permissions of the calling process (lpd). This option is only valid for typical "single-user" systems, where a user wants direct access to an apsfilterrc without having to become root to make changes. A more conveniant way on a multi-user system, where security is an issue, is that a system administrator creates user-specific apsfilterrc files. Addi‐ tional informations can be found in the apsfilter handbook and in the aps‐ filterrc file together with some examples. FILES /etc/apsfilter/apsfilterrc apsfilter global config file, settings are overwriteable by more specific printer config files, see below. /etc/apsfilter/QUEUE/apsfilterrc apsfilter config file on a per printer queue basis. This file has prefer‐ ence over the global config file. /etc/apsfilter/QUEUE/apsfilterrc.USER apsfilter config file on a per user basis (per print queue). This file has preference over the global and the printer queue specific config file. $HOME/.apsfilter/apsfilterrc.QUEUE A user defineable config file on a per printer queue basis. This file has preference over the global, the printer queue specific and the central per user config file, which is administered by a system administrator. Enabling this has a deep impact on your systems security, should NOT be used, especially on multi-user systems and is therefore disabled by default. See comments to USE_USER_CODE variable. SEE ALSO apsfilter(1), printcap(5) BUGS See apsfilter software center - http://www.apsfilter.org/ - for new versions, bugfixes and known bugs. Please use the new tool apsfilter-bug(1) to release bug- or problem reports. It automati‐ cally presents you a form in an editor window which asks you some standard questions. If you save and quit the editor session, then this report is sent automatically via e-mail to the proper apsfilter mailinglist. If apsfilter fails to print something or prints it in a way you wouldn't expect and you want to report an apsfilter error then please save the debugging output of one print session using the new aps2file(1) utility by typing aps2file -D -Z options file > /dev/null 2> file.debug and including the debugging output in the file file.debug into the edit session of the apsfilter-bug utility, so that it is included into the mail to the apsfilter mail‐ inglist. Please note that you need to run /bin/sh (Bourne Shell), bash or a compatible shell, so that the above mentioned output redirection works. Under C-shell (/bin/csh) or tcsh it would't work. If you don't know, then simply make sure you use the Bournce shell by typing /bin/sh or bash, then you should have no problems with redirection of stdout and stderr (> /dev/null 2> file.debug). DOCUMENTATION See official apsfilter homepage http://www.apsfilter.org/handbook.html Apsfilter Handbook including the Frequently Asked Questions (FAQ) USER FORUM Please send questions to the official apsfilter help channel @apsfilter.org. The above section BUGS and the file HOWTO-BUGREPORTS tells you how to report bugs. If you want to know how to troubleshoot your apsfilter installation, please read the manpage aps2file(1) and apsfilter-bug(1) as well as the Apsfilter Handbook carefully. HISTORY Apsfilter developement started in 1994. The apsfilterrc file on a "per printer queue" basis appeared in apsfilter 5.4.0.BSD April 08, 2000 BSD
|This manual||Reference||Other manuals|
|apsfilterrc(5)||referred by||aps2file(1) | apsfilter(1) | apspreview(1)|
|refer to||aps2file(1) | apsfilter(1) | apsfilter-bug(1) | printcap(5)|