ARCMSR(4FREEBSD) - Linux man page online | Special files
Areca RAID Controller driver.
December 4, 2015
ARCMSR(4) BSD Kernel Interfaces Manual ARCMSR(4)
BSD December 4, 2015 BSD
NAMEarcmsr — Areca RAID Controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device pci device scbus device da device arcmsr Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): arcmsr_load="YES"
DESCRIPTIONThe arcmsr driver provides support for the Areca ARC-11xx, ARC-12xx, ARC-13xx, ARC-16xx and ARC-18xx series of SAS and SATA RAID controllers. These controllers feature RAID-0, 1, 3, 5, 6, and 10 and JBOD acceleration for up to 16 SATA drives. RAID level and stripe level migration, online capacity expansion, hot insertion/removal, automatic failover and rebuild, and SMART are also supported. Access to the arrays is provided via the SCSI CAM /dev/da? device nodes. A management interface is also present via the /dev/arcmsr? device node. Management tools for i386 and amd64 are available from Areca.
HARDWAREThe arcmsr driver supports the following cards: · ARC-1110 · ARC-1120 · ARC-1130 · ARC-1160 · ARC-1170 · ARC-1110ML · ARC-1120ML · ARC-1130ML · ARC-1160ML · ARC-1200 · ARC-1201 · ARC-1203 · ARC-1210 · ARC-1212 · ARC-1213 · ARC-1214 · ARC-1220 · ARC-1222 · ARC-1223 · ARC-1224 · ARC-1230 · ARC-1231 · ARC-1260 · ARC-1261 · ARC-1270 · ARC-1280 · ARC-1210ML · ARC-1220ML · ARC-1231ML · ARC-1261ML · ARC-1280ML · ARC-1380 · ARC-1381 · ARC-1680 · ARC-1681 · ARC-1880 · ARC-1882 · ARC-1883
FILES/dev/da? Array block device /dev/arcmsr? Management interface
SEE ALSOda(4), scbus(4)
HISTORYThe arcmsr driver first appeared in FreeBSD 5.4.
AUTHORSThe driver was written by Erich Chen <@areca.com.tw>.
BUGSThe driver has been tested on i386 and amd64. It likely requires additional work to func‐ tion on big-endian architectures.
|This manual||Reference||Other manuals|
|refer to||da(4freebsd) | scbus(4freebsd)|