ATKBDC(4FREEBSD) - Linux man page online | Special files
The AT keyboard controller interface.
February 9, 1999
ATKBDC(4) BSD Kernel Interfaces Manual ATKBDC(4)
BSD February 9, 1999 BSD
NAMEatkbdc — the AT keyboard controller interface
SYNOPSISoptions KBD_RESETDELAY=N options KBD_MAXWAIT=N options KBDIO_DEBUG=N device atkbdc In /boot/device.hints: hint.atkbdc.0.at="isa" hint.atkbdc.0.port="0x060"
DESCRIPTIONThe keyboard controller atkbdc provides I/O services for the AT keyboard and PS/2 mouse style pointing devices. This controller is required for the keyboard driver atkbd and the PS/2 pointing device driver psm. There can be only one atkbdc device configured in the system.
DRIVER CONFIGURATIONKernel Configuration Options The following kernel configuration options can be used to control the atkbdc driver. They may be set in the kernel configuration file (see config(8)). KBD_RESETDELAY=X, KBD_MAXWAIT=Y The keyboard driver atkbd and the pointing device driver psm may ask the atkbdc driver to reset these devices during the boot process. It sometimes takes a long time before these devices respond to the reset command. These options control how long the atkbdc driver should wait before eventually giving up -- the driver will wait X * Y msecs at most. If the drivers seem unable to detect devices, you may want to increase these values. The default values are 200 msec for X and 5 for Y. KBDIO_DEBUG=N Sets the debug level to N. The default value is zero, which suppresses all debugging output.
SEE ALSOatkbd(4), psm(4), config(8)
HISTORYThe atkbdc driver first appeared in FreeBSD 3.1. It is based on the kbdio module in FreeBSD 2.2.
AUTHORSThe kbdio module, the atkbdc driver and this manual page were written by Kazutaka Yokota <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|atkbdc(4freebsd)||referred by||atkbd(4freebsd) | psm(4freebsd) | sc(4freebsd) | syscons(4freebsd) | vkbd(4freebsd) | vt(4freebsd)|
|refer to||atkbd(4freebsd) | psm(4freebsd)|