ATRTC(4FREEBSD) - Linux man page online | Special files
AT Real-Time Clock (RTC) driver.
September 17, 2010
ATRTC(4) BSD Kernel Interfaces Manual ATRTC(4)
BSD September 17, 2010 BSD
NAMEatrtc — AT Real-Time Clock (RTC) driver
SYNOPSISThis driver is a mandatory part of i386/amd64 kernels. The following tunable is settable from the loader(8): hint.atrtc.X.clock controls event timers functionality support. Setting to 0, disables it. Default value is 1.
DESCRIPTIONThis driver uses RTC hardware to supply kernel with time-of-day clock with 1 second resolu‐ tion and one event timer. This hardware uses base frequency of 32768Hz for advancing time- of-day clock and generating periodic interrupts. Interrupts could be generated with fixed number of frequencies, from 2Hz to 8192Hz, obtained by dividing base frequency by one of supported power-of-2 divisors. Event timer provided by the driver is irrelevant to CPU power states.
SEE ALSOapic(4), attimer(4), eventtimers(4), hpet(4)
|This manual||Reference||Other manuals|
|atrtc(4freebsd)||referred by||acpi_hpet(4freebsd) | apic(4freebsd) | attimer(4freebsd) | eventtimers(4freebsd) | hpet(4freebsd) | i8254(4freebsd)|
|refer to||apic(4freebsd) | attimer(4freebsd) | eventtimers(4freebsd) | hpet(4freebsd)|