BT(4FREEBSD) - Linux man page online | Special files
Buslogic/Mylex MultiMaster SCSI host adapter driver.
June 18, 2006
BT(4) BSD Kernel Interfaces Manual BT(4)
BSD June 18, 2006 BSD
NAMEbt — Buslogic/Mylex MultiMaster SCSI host adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device isa device scbus device bt In /boot/device.hints: hint.bt.0.at="isa" hint.bt.0.port="0x330"
DESCRIPTIONThis driver provides access to the SCSI bus connected to a Buslogic/Mylex MultiMaster or compatible controller: MultiMaster "W" Series Host Adapters: Adapter Bus Commands Description BT-948 PCI 192 Ultra SCSI-3 BT-958 PCI 192 Wide Ultra SCSI-3 BT-958D PCI 192 Wide Differential Ultra SCSI-3 MultiMaster "C" Series Host Adapters: Adapter Bus Commands Description BT-946C PCI 100 Fast SCSI-2 BT-956C PCI 100 Wide Fast SCSI-2 BT-956CD PCI 100 Wide Differential Fast SCSI-2 BT-445C VLB 100 Fast SCSI-2 BT-747C EISA 100 Fast SCSI-2 BT-757C EISA 100 Wide Fast SCSI-2 BT-757CD EISA 100 Wide Differential Fast SCSI-2 BT-545C ISA 50 Fast SCSI-2 BT-540CF ISA 50 Fast SCSI-2 MultiMaster "S" Series Host Adapters: Adapter Bus Commands Description BT-445S VLB 30 Fast SCSI-2 BT-747S EISA 30 Fast SCSI-2 BT-747D EISA 30 Differential Fast SCSI-2 BT-757S EISA 30 Wide Fast SCSI-2 BT-757D EISA 30 Wide Differential Fast SCSI-2 BT-545S ISA 30 Fast SCSI-2 BT-542D ISA 30 Differential Fast SCSI-2 BT-742A EISA 30 SCSI-2 (742A revision H) BT-542B ISA 30 SCSI-2 (542B revision H) MultiMaster "A" Series Host Adapters: Adapter Bus Commands Description BT-742A EISA 30 SCSI-2 (742A revisions A - G) BT-542B ISA 30 SCSI-2 (542B revisions A - G) Tagged queueing is supported on 'W' series adapters, 'C' series adapters with firmware of rev 4.42 and higher, and 'S' series adapters with firmware of rev 3.35 and higher. Boards with certain firmware revisions may lock up under heavy load to certain devices, especially if tagged queueing is used. Should you encounter a problem with your adapter, contact Mylex technical support and ensure you have the latest firmware for your controller.
HARDWAREThe bt driver supports the following BusLogic MultiMaster “W”, “C”, “S”, and “A” series and compatible SCSI host adapters: · BusLogic BT-445C · BusLogic BT-445S · BusLogic BT-540CF · BusLogic BT-542B · BusLogic BT-542B · BusLogic BT-542D · BusLogic BT-545C · BusLogic BT-545S · BusLogic/BusTek BT-640 · BusLogic BT-742A · BusLogic BT-742A · BusLogic BT-747C · BusLogic BT-747D · BusLogic BT-747S · BusLogic BT-757C · BusLogic BT-757CD · BusLogic BT-757D · BusLogic BT-757S · BusLogic BT-946C · BusLogic BT-948 · BusLogic BT-956C · BusLogic BT-956CD · BusLogic BT-958 · BusLogic BT-958D · Storage Dimensions SDC3211B / SDC3211F AMI FastDisk Host Adapters that are true BusLogic MultiMaster clones are also supported by the bt driver.
SEE ALSOcd(4), da(4), sa(4), scsi(4)
HISTORYThe bt driver first appeared in the 386BSD patch kit.
AUTHORSJulian Elischer wrote a driver for the Multimaster cards that appeared in the 386BSD patch kit. The driver was rewritten by Justin T. Gibbs to take advantage of new board features and work with the CAM SCSI framework in FreeBSD 3.0. Special thanks to Leonard N. Zubkoff for writing such a complete and well documented Mylex/BusLogic MultiMaster driver for Linux. Support in this driver for the wide range of MultiMaster controllers and firmware revisions, with their otherwise undocumented quirks, would not have been possible without his efforts.
|This manual||Reference||Other manuals|
|bt(4freebsd)||referred by||CAM(4freebsd) | cam(4freebsd) | scbus(4freebsd) | SCSI(4freebsd) | scsi(4freebsd)|
|refer to||cd(4freebsd) | da(4freebsd) | sa(4freebsd)|