BYTGPIO(4FREEBSD) - Linux man page online | Special files
Intel Bay Trail SoC GPIO controller.
May 9, 2017
BYTGPIO(4) BSD Kernel Interfaces Manual BYTGPIO(4)
BSD May 9, 2017 BSD
NAMEbytgpio — Intel Bay Trail SoC GPIO controller
SYNOPSISdevice gpio device bytgpio
DESCRIPTIONThe bytgpio is a driver for GPIO controller that can be found in Intel's Bay Trail SoC fam‐ ily. Bay Trail SoC has three banks of GPIO pins exposed to userland as /dev/gpiocN, where N is 0, 1, and 2. Pins in each bank are pre-named to match names on boards schematics: GPIO_S0_SCnn, GPIO_S0_NCnn, and GPIO_S5_nn.
SEE ALSOgpio(3), gpio(4), gpioctl(8)
HISTORYThe bytgpio manual page first appeared in FreeBSD 11.1.
AUTHORSThis driver and man page was written by Oleksandr Tymoshenko <@FreeBSD.org>.
|This manual||Reference||Other manuals|