CALENDARSERVER_EXPORT(8) - Linux man page online | Administration and privileged commands
Calendar Server export tool.
November 6, 2008
CALENDARSERVER_EXPORT(8) BSD System Manager's Manual CALENDARSERVER_EXPORT(8)
BSD November 6, 2008 BSD
NAMEcalendarserver_export — Calendar Server export tool
SYNOPSIScalendarserver_export [-f config_file] [-o output_file] [-c collection] [-H home] [-r record] [-u user]
DESCRIPTIONcalendarserver_export is a tool that generates a single iCalendar file containing all of the iCalendar components found from all specified input sources, providing server administrators a means by which to export data from the Calandar Server into a format that can be viewed and/or manipulated by other tools. Multiple input sources may be specified; the resulting iCalendar data will contain the combined data from all sources.
OPTIONS-h, --help Displays usage information -f, --config FILE Use the Calendar Server configuration specified in the given file. -o, --output FILE Write resulting iCalendar data to the given file. -c, --collection DIRECTORY Read iCalendar objects from the calendar collection at the given path. -h, --home DIRECTORY Read iCalendar objects from all calendar collections within the calendar home at the given path. -r, --record TYPE:NAME Read iCalendar objects from all calendar collections within the calendar home for the directory record of the given type with the given name. -u, --user NAME Read iCalendar objects from all calendar collections within the calendar home for the directory user with the given name. This is shorthand for -r user:NAME.
FILES/etc/caldavd/caldavd.plist The Calendar Server configuration file. /Library/CalendarServer/Documents The server's document root, which is the used as the backing store for the HTTP resources on the server.
STANDARDSThe iCalendar data generated by calendarserver_export is expected to comply with RFC 2445 (iCalendar).
|This manual||Reference||Other manuals|