CALENDARSERVER_PURGE_ATTACHMENTS(8) - Linux man page online | Administration and privileged commands
Calendar Server orphaned attachments clean-up utility.
June 17, 2009
CALENDARSERVER_PURGE_ATTACHMENT... BSD System Manager's Manual CALENDARSERVER_PURGE_ATTACHMENT...
BSD June 17, 2009 BSD
NAMEcalendarserver_purge_attachments — Calendar Server orphaned attachments clean-up utility
SYNOPSIScalendarserver_purge_attachments [--config file] [--uuid guid] [--days NUMBER] [--dry-run] [--verbose] [--help]
DESCRIPTIONcalendarserver_purge_attachments is a tool for removing attachments that are no longer ref‐ erenced by any calendar events, or only referenced by events older than a specified cut-off. calendarserver_purge_attachments should be run as a user with the same privileges as the Calendar Server itself, as it needs to read and write data that belongs to the server.
OPTIONS-h, --help Display usage information -f, --config FILE Use the Calendar Server configuration specified in the given file. Defaults to /etc/caldavd/caldavd.plist. -u, --uuid GUID Target a specific user via their GUID. -d, --days NUMBER Specify how many days in the past to retain. Defaults to 365 days. -n, --dry-run Calculate and display how many orphaned attachments would be removed, but don't actu‐ ally remove them. -v, --verbose Print progress information.
FILES/etc/caldavd/caldavd.plist The Calendar Server configuration file.
|This manual||Reference||Other manuals|