CALENDARSERVER_PURGE_EVENTS(8) - Linux man page online | Administration and privileged commands
Calendar Server event clean-up utility.
June 17, 2009
CALENDARSERVER_PURGE_EVENTS(8) BSD System Manager's Manual CALENDARSERVER_PURGE_EVENTS(8)
BSD June 17, 2009 BSD
NAMEcalendarserver_purge_events — Calendar Server event clean-up utility
SYNOPSIScalendarserver_purge_events [--config file] [--days number] [--dry-run] [--verbose] [--help]
DESCRIPTIONcalendarserver_purge_events is a tool for removing old events from the calendar server. By default, events older than 365 days are removed, but the user can specify the number of days in the past to use as a cut-off. Repeating events that have any occurrences after the cut- off day are not removed. calendarserver_purge_events should be run as a user with the same privileges as the Calendar Server itself, as it needs to read and write data that belongs to the server.
OPTIONS-h, --help Display usage information -f, --config FILE Use the Calendar Server configuration specified in the given file. Defaults to /etc/caldavd/caldavd.plist. -d, --days NUMBER Specify how many days in the past to retain. Defaults to 365 days. -n, --dry-run Calculate and display how many events would be removed, but don't actually remove them. -v, --verbose Print progress information.
FILES/etc/caldavd/caldavd.plist The Calendar Server configuration file.
|This manual||Reference||Other manuals|