CALENDARSERVER_PURGE_PRINCIPALS(8) - Linux man page online | Administration and privileged commands
Calendar Server deprovisioned user clean-up utility.
June 17, 2009
CALENDARSERVER_PURGE_PRINCIPALS(8) BSD System Manager's Manual CALENDARSERVER_PURGE_PRINCIPALS(8)
BSD June 17, 2009 BSD
NAMEcalendarserver_purge_principals — Calendar Server deprovisioned user clean-up utility
SYNOPSIScalendarserver_purge_principals [--completely] [--config file] [--dry-run] [--verbose] [--help] guid [guid ...]
DESCRIPTIONcalendarserver_purge_principals is a tool for removing one or more principals' future events, proxy assignments, and contacts from the calendar server. By default, events in the past are retained, but any ongoing events are canceled. calendarserver_purge_principals should be run as a user with the same privileges as the Cal‐ endar Server itself, as it needs to read and write data that belongs to the server.
OPTIONS-h, --help Display usage information -c, --completely Delete/cancel all events -f, --config FILE Use the Calendar Server configuration specified in the given file. Defaults to /etc/caldavd/caldavd.plist. -n, --dry-run Calculate and display how many events and contacts would be removed, but don't actu‐ ally remove them. -v, --verbose Print progress information.
FILES/etc/caldavd/caldavd.plist The Calendar Server configuration file.
|This manual||Reference||Other manuals|