CERTPATCH(8) - Linux man page online | Administration and privileged commands
Add subjectAltName identities to X.509 certificates.
July 18, 1999
CERTPATCH(8) BSD System Manager's Manual CERTPATCH(8)
BSD July 18, 1999 BSD
NAMEcertpatch — add subjectAltName identities to X.509 certificates
SYNOPSIScertpatch [-t identity-type] -i identity -k signing-key input-certificate output-certificate
DESCRIPTIONcertpatch alters PEM-encoded X.509 certificates by adding a subjectAltName extension con‐ taining an identity used by the signature-based authentication schemes of the ISAKMP proto‐ col. After the addition the certificate will be signed once again with the supplied CA signing key. The options are as follows: -t identity-type If given, the -t option specifies the type of the given identity. Currently ip, fqdn, and ufqdn are recognized. The default is ip. -i identity The -i option takes an argument which is the identity to put into the subjectAltName field of the certificate. If the identity-type is ip, this argument should be an IPv4 address in dotted decimal notation. -k signing-key The -k option specifies the key used for signing the certificate once the subjec‐ tAltName extension has been added. The key is specified by the filename where it is stored in PEM format.
SEE ALSOisakmpd(8), ssl(8)
|This manual||Reference||Other manuals|
|certpatch(8)||referred by||isakmpd(8) | isakmpd.conf(5)|