CHROMEBOOK_PLATFORM(4FREEBSD) - Linux man page online | Special files
Support driver for hardware on various Chromebook models.
October 13, 2016
CHROMEBOOK_PLATFORM(4) BSD Kernel Interfaces Manual CHROMEBOOK_PLATFORM(4)
BSD October 13, 2016 BSD
NAMEchromebook_platform — support driver for hardware on various Chromebook models
SYNOPSISTo compile this driver into the kernel, place the following lines into the kernel configura‐ tion file: device chromebook_platform Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): chromebook_platform_load="YES"
DESCRIPTIONThe chromebook_platform driver provides automatic configuration for devices that cannot be enumerated or safely probed. In particular, I2C peripherals are different from model to model. chromebook_platform has a model-specific information about the I2C peripherals, their drivers, their bus attachments and slave addresses. Note that chromebook_platform does not load driver modules for the peripherals. Those have to be compiled into the kernel or loaded separately.
SEE ALSOcyapa(4), iicbus(4), isl(4),
AUTHORSThe chromebook_platform driver and this manual page were written by Andriy Gapon <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||cyapa(4freebsd) | iicbus(4freebsd) | isl(4freebsd)|