CORETEMP(4FREEBSD) - Linux man page online | Special files
Device driver for Intel Core on-die digital thermal sensor.
August 23, 2007
CORETEMP(4) BSD Kernel Interfaces Manual CORETEMP(4)
BSD August 23, 2007 BSD
NAMEcoretemp — device driver for Intel Core on-die digital thermal sensor
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device coretemp Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): coretemp_load="YES"
DESCRIPTIONThe coretemp driver provides support for the on-die digital thermal sensor present in Intel Core and newer CPUs. The coretemp driver reports each core's temperature through a sysctl node in the correspond‐ ing CPU device's sysctl tree, named dev.cpu.%d.temperature.
HISTORYThe coretemp driver first appeared in FreeBSD 7.0.
AUTHORSThe coretemp driver was written by Rui Paulo <@FreeBSD.org> as part of a Google Summer of Code project. This manual page was written by Dag-Erling Smørgrav <@FreeBSD.org>.
|This manual||Reference||Other manuals|