CR_SEEOTHERUIDS(9FREEBSD) - Linux man page online | System kernel interfaces
Determine visibility of objects given their user credentials.
November 11, 2003
CR_SEEOTHERUIDS(9) BSD Kernel Developer's Manual CR_SEEOTHERUIDS(9)
BSD November 11, 2003 BSD
NAMEcr_seeotheruids — determine visibility of objects given their user credentials
SYNOPSISint cr_seeotheruids(struct ucred *u1, struct ucred *u2);
DESCRIPTIONThis function determines the visibility of objects in the kernel based on the real user IDs in the credentials u1 and u2 associated with them. The visibility of objects is influenced by the sysctl(8) variable security.bsd.see_other_uids. If this variable is non-zero then all objects in the kernel are visible to each other irrespective of their user IDs. If this variable is zero then the object with credentials u2 is visible to the object with credentials u1 if either u1 is the super-user credential, or if u1 and u2 have the same real user ID.
SYSCTL VARIABLESsecurity.bsd.see_other_uids Must be non-zero if objects with unprivileged credentials are to be able to see each other.
RETURN VALUESThis function returns zero if the object with credential u1 can “see” the object with cre‐ dential u2, or ESRCH otherwise.
SEE ALSOcr_seeothergids(9), p_candebug(9)
|This manual||Reference||Other manuals|
|cr_seeotheruids(9freebsd)||referred by||cr_cansee(9freebsd) | cr_seeothergids(9freebsd) | p_candebug(9freebsd)|
|refer to||cr_seeothergids(9freebsd) | p_candebug(9freebsd) | sysctl(8)|