DEVICE_DELETE_CHILD(9FREEBSD) - Linux man page online | System kernel interfaces
Delete a child from a device.
June 16, 1998
DEVICE_DELETE_CHILD(9) BSD Kernel Developer's Manual DEVICE_DELETE_CHILD(9)
BSD June 16, 1998 BSD
NAMEdevice_delete_child — delete a child from a device
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int device_delete_child(device_t dev, device_t child);
DESCRIPTIONThe specified device is removed from dev and deleted. If the device is currently attached, it is first detached (see DEVICE_ATTACH(9) and DEVICE_DETACH(9)).
RETURN VALUESZero is returned on success, otherwise an error is returned.
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|refer to||device_add_child(9freebsd) | DEVICE_ATTACH(9freebsd) | DEVICE_DETACH(9freebsd)|