DEVICE_PROBE_AND_ATTACH(9FREEBSD) - man page online | system kernel interfaces
Initialise a device.
June 16, 1998
DEVICE_PROBE_AND_ATTACH(9) BSD Kernel Developer's Manual DEVICE_PROBE_AND_ATTACH(9)
NAMEdevice_probe_and_attach — initialise a device
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int device_probe_and_attach(device_t dev);
DESCRIPTIONThis function is called during autoconfiguration to initialise the devices in the system. For each device, the DEVICE_PROBE(9) method of each suitable driver is called and if a probe succeeds, a description of the device is printed and the DEVICE_ATTACH(9) method is called. If the device is disabled using device_disable(9) then it will not be probed.
RETURN VALUESZero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevice(9), driver(9)
BSD June 16, 1998 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|device_probe_and_attach(9freebsd)||referred by||bus_generic_attach(9freebsd) | bus_generic_new_pass(9freebsd)|
|refer to||device(9freebsd) | DEVICE_ATTACH(9freebsd) | device_disable(9freebsd) | DEVICE_PROBE(9freebsd) | driver(9freebsd)|