DEVICE_SET_DRIVER(9FREEBSD) - Linux man page online | System kernel interfaces
Associate a specific driver with a device node in the tree.
April 21, 2003
DEVICE_SET_DRIVER(9) BSD Kernel Developer's Manual DEVICE_SET_DRIVER(9)
BSD April 21, 2003 BSD
NAMEdevice_set_driver — associate a specific driver with a device node in the tree
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> void device_set_driver(device_t dev, driver_t *driver);
DESCRIPTIONThis function associates a specific driver with a given device node in the tree. It is typ‐ ically used in DEVICE_IDENTIFY(9) functions to add devices to a bus that does not support doing so automatically, such as the ISA bus.
AUTHORSThis manual page was written by M. Warner Losh.
|This manual||Reference||Other manuals|
|refer to||device(9freebsd) | DEVICE_IDENTIFY(9freebsd)|