DEVICE_VERBOSE(9FREEBSD) - Linux manual page online | System kernel interfaces
Manipulate device quiet flag.
September 12, 2016
DEVICE_QUIET(9) BSD Kernel Developer's Manual DEVICE_QUIET(9)
BSD September 12, 2016 BSD
NAMEdevice_quiet, device_verbose, device_is_quiet — manipulate device quiet flag
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> void device_quiet(device_t dev); void device_verbose(device_t dev); int device_is_quiet(device_t dev);
DESCRIPTIONEach device has a quiet flag associated with it. A device is verbose by default when it is created but may be quieted to prevent printing of the device identification string during attach and printing of a message during detach. To quiet a device, call device_quiet() dur‐ ing a device driver probe routine. To re-enable probe messages, call device_verbose(). To test to see if a device is quieted, call device_is_quiet(). Devices are implicitly marked verbose after a driver detaches.
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|refer to||device(9freebsd) | device_quiet(9freebsd)|