DEVTONAME(9FREEBSD) - man page online | system kernel interfaces
Converts character device into a string indicating the device name.
February 10, 2012
DEVTONAME(9) BSD Kernel Developer's Manual DEVTONAME(9)
NAMEdevtoname — converts character device into a string indicating the device name
SYNOPSIS#include <sys/param.h> #include <sys/conf.h> const char * devtoname(struct cdev *dev);
DESCRIPTIONThe devtoname() function returns a pointer to the name of the device passed to it. The name is whatever was set to it in make_dev().
BSD February 10, 2012 BSD
HISTORYThe devtoname() interface first appeared in FreeBSD 4.0