DUMMYNET(4FREEBSD) - Linux man page online | Special files
Traffic shaper, bandwidth manager and delay emulator.
October 28, 2002
DUMMYNET(4) BSD Kernel Interfaces Manual DUMMYNET(4)
BSD October 28, 2002 BSD
NAMEdummynet — traffic shaper, bandwidth manager and delay emulator
DESCRIPTIONThe dummynet system facility permits the control of traffic going through the various net‐ work interfaces, by applying bandwidth and queue size limitations, implementing different scheduling and queue management policies, and emulating delays and losses. The user interface for dummynet is implemented by the ipfw(8) utility, so please refer to the ipfw(8) manpage for a complete description of the dummynet capabilities and how to use it. Kernel Options The following options in the kernel configuration file are related to dummynet operation: IPFIREWALL enable ipfirewall (required for dummynet) IPFIREWALL_VERBOSE enable firewall output IPFIREWALL_VERBOSE_LIMIT limit firewall output DUMMYNET enable dummynet operation HZ set the timer granularity Generally, the following options are required: options IPFIREWALL options DUMMYNET options HZ=1000 # strongly recommended Additionally, one may want to increase the number of mbuf clusters (used to store network packets) according to the sum of the bandwidth-delay products and queue sizes of all config‐ ured pipes.
SEE ALSOsetsockopt(2), if_bridge(4), ip(4), ipfw(8), sysctl(8)
HISTORYThe dummynet facility was initially implemented as a testing tool for TCP congestion control by Luigi Rizzo <@iet.unipi.it>, as described on ACM Computer Communication Review, Jan.97 issue. Later it has been modified to work at the IP and bridging levels, integrated with the ipfw(4) packet filter, and extended to support multiple queueing and scheduling policies.
|This manual||Reference||Other manuals|
|dummynet(4freebsd)||referred by||bridge(4freebsd) | if_bridge(4freebsd) | multicast(4freebsd) | securelevel(7freebsd) | security(7freebsd) | siftr(4freebsd)|
|refer to||getsockopt(2) | if_bridge(4freebsd) | ip(4freebsd) | ipfw(4freebsd) | sysctl(8)|