EN(4FREEBSD) - Linux man page online | Special files
Device driver for Midway-based ATM interfaces.
July 16, 2005
EN(4) BSD Kernel Interfaces Manual EN(4)
BSD July 16, 2005 BSD
NAMEen — device driver for Midway-based ATM interfaces
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device en device atm device utopia Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_en_load="YES"
DESCRIPTIONThe en device driver supports Midway-based ATM interfaces including the Efficient Networks, Inc. ENI-155 and Adaptec ANA-59x0. Midway is an AAL5 SAR (Segmentation and Reassembly) chip. For configuring the card for IP see natmip(4). The following sysctls are recognized by the driver additionally to those handled by utopia(4): hw.atm.enX.istats Contains an array of uint32_t with internal driver statistics. hw.atm.enX.debug This is a bit map of debugging options. This variable is only available when the driver is compiled with debugging support. The driver supports the media options sdh, noscramb and unassigned (see utopia(4)).
DIAGNOSTICSen0 <Efficient Networks ENI-155p> rev 0 int a irq 5 on pci0:16 en0: ATM midway v0, board IDs 6.0, Utopia (pipelined), 512KB on-board RAM en0: maximum DMA burst length = 64 bytes en0: 7 32KB receive buffers, 8 32KB transmit buffers allocated
SEE ALSOnatm(4), natmip(4), utopia(4), ifconfig(8), route(8)
AUTHORSChuck Cranor of Washington University implemented en driver in 1996 for NetBSD.
CAVEATSThe driver extensively uses DMA on PCI. The first generation PCI chipsets do not work or exhibit poor performance.
|This manual||Reference||Other manuals|
|en(4freebsd)||referred by||if_en(4freebsd) | natm(4freebsd) | natmip(4freebsd) | utopia(4freebsd)|
|refer to||ifconfig(8) | natm(4freebsd) | natmip(4freebsd) | route(8) | utopia(4freebsd)|