EST(4FREEBSD) - Linux man page online | Special files
Enhanced Speedstep Technology.
October 18, 2012
EST(4) BSD Kernel Interfaces Manual EST(4)
BSD October 18, 2012 BSD
NAMEest — Enhanced Speedstep Technology
SYNOPSISTo compile this capability into your kernel place the following line in your kernel configu‐ ration file: device cpufreq
DESCRIPTIONThe est interface provides support for the Intel Enhanced Speedstep Technology. Note that est capabilities are automatically loaded by the cpufreq(4) driver.
LOADER TUNABLESThe est interface is intended to allow cpufreq(4) to access and implement Intel Enhanced SpeedStep Technology via acpi(4) and the acpi_perf interface accessors. If the default set‐ tings are not optimal, the following sysctls can be used to modify or monitor est behavior. hw.est.msr_info Attempt to infer information from direct probing of the msr. Should only be used in diagnostic cases. (default 0) hw.est.strict Validate frequency requested is accepted by the cpu when set. It appears that this will only work on single core cpus. (default 0)
SYSCTL VARIABLESThe following sysctl(8) values are available dev.est.%d.desc Description of support, almost always Enhanced SpeedStep Frequency Control. dev.est.0.%desc: Enhanced SpeedStep Frequency Control dev.est.%d.driver Driver in use, always est. dev.est.0.%driver: est dev.est.%d.parent dev.est.0.%parent: cpu0 The cpu that is exposing these frequencies. For example cpu0. dev.est.%d.freq_settings. The valid frequencies that are allowed by this CPU and their step values. dev.est.0.freq_settings: 2201/45000 2200/45000 2000/39581 1900/37387 1800/34806 1700/32703 1600/30227 1500/28212 1400/25828 1300/23900 1200/21613 1100/19775 1000/17582 900/15437 800/13723
DIAGNOSTICSest%d: <Enhanced SpeedStep Frequency Control> on cpu%d Indicates normal startup of this interface. est: CPU supports Enhanced Speedstep, but is not recognized. est: cpu_vendor GenuineIntel, msr 471c471c0600471c device_attach: est%d attach returned 6 Indicates all attempts to attach to this interface have failed. This usually indicates an improper BIOS setting restricting O/S control of the CPU speeds. Consult your BIOS documen‐ tation for more details.
COMPATIBILITYest is only found on supported Intel CPUs.
SEE ALSOcpufreq(4) Intel 64 and IA-32 Architectures Software Developer Manuals, http://www.intel.com/content/www/us/en/processors/architectures-software-developer- manuals.html.
AUTHORSThis manual page was written by Sean Bruno <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||acpi(4freebsd) | cpufreq(4freebsd) | sysctl(8)|