EXTATTR(9FREEBSD) - Linux man page online | System kernel interfaces
Virtual file system named extended attributes.
December 23, 1999
EXTATTR(9) BSD Kernel Developer's Manual EXTATTR(9)
BSD December 23, 1999 BSD
NAMEextattr — virtual file system named extended attributes
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> #include <sys/extattr.h>
DESCRIPTIONNamed extended attributes allow additional meta-data to be associated with vnodes represent‐ ing files and directories. The semantics of this additional data is that of a "name=value" pair, where a name may be defined or undefined, and if defined, associated with zero or more bytes of arbitrary binary data. Extended attribute names exist within a set of namespaces; each operation on an extended attribute is required to provide the namespace to which to operation refers. If the same name is present in multiple namespaces, the extended attributes associated with the names are stored and manipulated independently. The follow‐ ing two namespaces are defined universally, although individual file systems may implement additional namespaces, or not implement these namespaces: EXTATTR_NAMESPACE_USER, EXTATTR_NAMESPACE_SYSTEM. The semantics of these attributes are intended to be as follows: user attribute data is protected according the normal discretionary and mandatory protec‐ tions associated with the data in the file or directory; system attribute data is protected such that appropriate privilege is required to directly access or manipulate these attributes. Reads of extended attribute data may return specific contiguous regions of the meta-data, in the style of VOP_READ(9), but writes will replace the entire current "value" associated with a given name. As there are a plethora of file systems with differing extended attributes, availability and functionality of these functions may be limited, and they should be used with awareness of the underlying semantics of the supporting file system. Authorization schemes for extended attribute data may also vary by file system, as well as maximum attribute size, and whether or not any or specific new attributes may be defined. Extended attributes are named using a null-terminated character string. Depending on under‐ lying file system semantics, this name may or may not be case-sensitive. Appropriate vnode extended attribute calls are: VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9), and VOP_SETEXTATTR(9).
SEE ALSOVFS(9), VFS_EXTATTRCTL(9), VOP_GETEXTATTR(9), VOP_LISTEXTATTR(9), VOP_SETEXTATTR(9)
AUTHORSThis manual page was written by Robert Watson.
BUGSIn addition, the interface does not provide a mechanism to retrieve the current set of available attributes; it has been suggested that providing a NULL attribute name should cause a list of defined attributes for the passed file or directory, but this is not cur‐ rently implemented.
|This manual||Reference||Other manuals|
|extattr(9freebsd)||referred by||extattr(2freebsd) | extattr_delete_fd(2freebsd) | extattr_delete_file(2freebsd) | extattr_delete_link(2freebsd) | extattr_get_fd(2freebsd) | extattr_get_file(2freebsd) | extattr_get_link(2freebsd) | extattr_list_fd(2freebsd) | extattr_list_file(2freebsd) | extattr_list_link(2freebsd) | extattr_set_fd(2freebsd) | extattr_set_file(2freebsd) | extattr_set_link(2freebsd) | VOP_GETEXTATTR(9freebsd) | VOP_LISTEXTATTR(9freebsd) | VOP_SETEXTATTR(9freebsd)|
|refer to||VFS(9freebsd) | VOP_GETEXTATTR(9freebsd) | VOP_LISTEXTATTR(9freebsd) | VOP_READ(9freebsd) | VOP_SETEXTATTR(9freebsd)|