GPM.CONF(5) - Linux man page online | File formats
Startup configuration file for gpm.
January 5, 2005
GPM.CONF(5) BSD File Formats Manual GPM.CONF(5)
Debian 3.0 January 5, 2005 Debian 3.0
NAMEgpm.conf — startup configuration file for gpm
DESCRIPTIONgpm.conf specifies options to be passed to the gpm daemon at start time. It is parsed by the init script, rather than by gpm itself. It comprises variable assignments in Bourne shell syntax: variable=value (with no extra spaces; to embed spaces or other shell metachar‐ acters in values, use quotes as in shell scripting). Blank lines and lines beginning with a hash ("#") are ignored. Settings are implemented by setting flags on the gpm command line; these are documented in gpm(8). The following variable names are specified: device Specifies the device file for your primary mouse. This sets -m. type Specifies the protocol for your primary mouse. This sets -t. device2, type2 The same as device and type, but for your secondary mouse. These set -m and -t after passing -M. If either of these are defined, both must be. responsiveness Specifies the responsiveness for your primary mouse. This sets -r. sample_rate Specifies the sample rate for your primary mouse. This sets -s. repeat_type Enables the gpm repeater and sets the repeater protocol, using the -R flag. Repeat type none or an empty value will disable the repeater. append Any options specified here are appended to the gpm command line. If you use multiple options, you will need to enclose the value in quotes ("").
EXAMPLESA simple gpm.conf file for a PS/2 mouse whose protocol should be autodetected, and which should be repeated in /dev/gpmdata as a serial Microsoft Intellimouse: # Sample gpm.conf device=/dev/psaux type=autops2 repeat_type=ms3 This will cause the daemon to be started as gpm -m /dev/psaux -t autops2 -Rms3.
SEE ALSOgpm(8), dpkg-reconfigure(8). dpkg-reconfigure gpm can be used to generate and update the gpm.conf file automatically.
|This manual||Reference||Other manuals|
|refer to||dpkg-reconfigure(8) | gpm(8)|