IF_ET(4FREEBSD) - Linux man page online | Special files
Agere ET1310 10/100/Gigabit Ethernet driver.
December 9, 2011
ET(4) BSD Kernel Interfaces Manual ET(4)
BSD December 9, 2011 BSD
NAMEet — Agere ET1310 10/100/Gigabit Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device et Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_et_load="YES"
DESCRIPTIONThe et driver supports PCI Express Ethernet adapters based on the Agere ET1310 chip. The et driver supports the following media types: autoselect Enable autoselection of the media types and options. The user can manually override the autoselected mode by adding media options to the /etc/rc.conf file. 10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 1000baseT Set 1000Mbps (Gigabit Ethernet) operation. The mediaopt option can only be set to full-duplex mode. The et driver supports the following media options: full-duplex Force full-duplex operation. half-duplex Force half-duplex operation. Note that the 1000baseT media type is only available if it is supported by the adapter. For more information on configuring this device, see ifconfig(8).
HARDWAREThe et driver supports Agere ET1310 10/100/Gigabit Ethernet adapters.
TUNABLEShw.et.rx_intr_npkts This value controls how many packets should be received before a receive interrupt is generated. The default value is 32. It is recom‐ mended to set this value above 38 to prevent the host from being live‐ locked under a high degree of stress. hw.et.rx_intr_delay This value delays the generation of receive interrupts in units of ~4 microseconds. It is used together with hw.et.rx_intr_npkts to achieve RX interrupt moderation. The default value is 20. hw.et.tx_intr_nsegs This value controls how many segments (not packets) should be transmit‐ ted before a transmit interrupt is generated. The default value is 126. It is recommended to set this value below 280 to prevent the TX ring from underflowing. hw.et.timer This value controls how often a timer interrupt should be generated. It is used together with hw.et.tx_intr_nsegs to achieve TX interrupt moderation. The default value is 1000000000 (nanoseconds).
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), vlan(4), ifconfig(8)
HISTORYThe et device driver first appeared in DragonFly 1.11. The first FreeBSD release to include it was FreeBSD 8.0.
AUTHORSThe et driver was written by Sepherosa Ziehau <@gmail.com> for DragonFly. It was ported to FreeBSD by Xin LI <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | et(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | vlan(4freebsd)|