IF_HME(4FREEBSD) - Linux man page online | Special files
Sun Microelectronics STP2002-STQ Ethernet interfaces device driver.
June 14, 2009
HME(4) BSD Kernel Interfaces Manual HME(4)
BSD June 14, 2009 BSD
NAMEhme — Sun Microelectronics STP2002-STQ Ethernet interfaces device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device hme Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_hme_load="YES"
DESCRIPTIONThe hme driver supports Sun Microelectronics STP2002-STQ “Happy Meal Ethernet” Fast Ethernet interfaces. All controllers supported by the hme driver have TCP checksum offload capability for both receive and transmit, support for the reception and transmission of extended frames for vlan(4) and a 128-bit multicast hash filter.
HARDWAREThe hme driver supports the on-board Ethernet interfaces of many Sun UltraSPARC workstation and server models. Cards supported by the hme driver include: · Sun PCI SunSwift Adapter (“SUNW,hme”) · Sun SBus SunSwift Adapter (“hme” and “SUNW,hme”) · Sun PCI Sun100BaseT Adapter 2.0 (“SUNW,hme”) · Sun SBus Sun100BaseT 2.0 (“SUNW,hme”) · Sun PCI Quad FastEthernet Controller (“SUNW,qfe”) · Sun SBus Quad FastEthernet Controller (“SUNW,qfe”)
NOTESOn sparc64 the hme driver respects the local-mac-address? system configuration variable which can be set in the Open Firmware boot monitor using the setenv command or by eeprom(8). If set to “false” (the default), the hme driver will use the system's default MAC address for all of its devices. If set to “true”, the unique MAC address of each interface is used if present rather than the system's default MAC address. Supported interfaces having their own MAC address include on-board versions on boards equipped with more than one Ethernet interface and all add-on cards except the single-port SBus versions.
SEE ALSOaltq(4), intro(4), miibus(4), netintro(4), vlan(4), eeprom(8), ifconfig(8) Sun Microelectronics, STP2002QFP Fast Ethernet, Parallel Port, SCSI (FEPS) User's Guide, http://mediacast.sun.com/users/Barton808/media/STP2002QFP-FEPs_UG.pdf, April 1996.
HISTORYThe hme driver first appeared in NetBSD 1.5. The first FreeBSD version to include it was FreeBSD 5.0.
AUTHORSThe hme driver was written by Paul Kranenburg <@NetBSD.org>.
|This manual||Reference||Other manuals|
|refer to||hme(4freebsd) | ifconfig(8) | intro(4) | miibus(4freebsd) | netintro(4freebsd) | vlan(4freebsd)|