IF_IXGB(4FREEBSD) - Linux man page online | Special files
Intel(R) PRO/10GbE Ethernet driver for the FreeBSD operating system.
August 18, 2006
IXGB(4) BSD Kernel Interfaces Manual IXGB(4)
BSD August 18, 2006 BSD
NAMEixgb — Intel(R) PRO/10GbE Ethernet driver for the FreeBSD operating system
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ixgb Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_ixgb_load="YES"
DESCRIPTIONThe ixgb driver provides support for PCI Gigabit Ethernet adapters based on the Intel 82597EX Ethernet controller chips. The driver supports Transmit/Receive checksum offload and Jumbo Frames. For questions related to hardware requirements, refer to the documentation supplied with your Intel PRO/10GbE adapter. All hardware requirements listed apply to use with FreeBSD. Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit Jumbo Frames. The maximum MTU size for Jumbo Frames is 16114. This driver version supports VLANs. For information on enabling VLANs, see ifconfig(8).
HARDWAREThe ixgb driver supports the following cards: · Intel PRO/10GbE LR Server Adapter · Intel PRO/10GbE SR Server Adapter
DIAGNOSTICSixgb%d: Unable to allocate bus resource: memory A fatal initialization error has occurred. ixgb%d: Unable to allocate bus resource: interrupt A fatal initialization error has occurred. ixgb%d: watchdog timeout -- resetting The device has stopped responding to the network, or there is a problem with the network connection (cable).
SUPPORTFor general information and support, go to the Intel support website at: http://support.intel.com. If an issue is identified with the released source code on the supported kernel with a sup‐ ported adapter, email the specific information related to the issue to ⟨@intel.com⟩.
SEE ALSOarp(4), em(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
HISTORYThe ixgb device driver first appeared in FreeBSD 4.11 and FreeBSD 5.3.
AUTHORSThe ixgb driver was written by Intel Corporation <@intel.com>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | em(4freebsd) | ifconfig(8) | ixgb(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | polling(4freebsd) | vlan(4freebsd)|