IF_IXLV(4FREEBSD) - Linux man page online | Special files
Intel XL710 Ethernet 40Gb VF driver.
IXLV(4) BSD Kernel Interfaces Manual IXLV(4)
BSD March 25, 2015 BSD
NAMEixlv — Intel XL710 Ethernet 40Gb VF driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ixlv To load the driver as a module at boot time, place the following lines in loader.conf(5): if_ixlv_load="YES"
DESCRIPTIONThe ixlv driver provides virtualization support for PCI Express adapters or LOMs in the XL710 Family of ethernet devices. The driver supports Jumbo Frames, TX/RX checksum offload, TCP segmentation offload (TSO), Large Receive Offload (LRO), VLAN tag insertion/extraction, VLAN checksum offload, VLAN TSO, and Receive Side Steering (RSS), all for both IPv4 and IPv6. For further hardware information and questions related to hardware requirements, see http://support.intel.com/. Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit Jumbo Frames. The maximum MTU size for Jumbo Frames is 9706. Offloads are also controlled via the interface, for instance, checksumming for both IPv4 and IPv6 can be set and unset, TSO4 and/or TSO6, and finally LRO can be set and unset. For more information on configuring this device, see ifconfig(8). NOTE: The ixlv driver is only used by means of SRIOV, normally in a VM on a hosting server with the ixl(4) driver.
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5). hw.ixlv.ringsz Set the number of descriptors in the rings, note that this changes BOTH the TX and RX rings, they cannot be set independently. hw.ixlv.max_queues Set the number of queues (each a TX/RX pair) for the port, this allows one to over‐ ride the autocalculation if it is set to 0. hw.ixlv.txbrsz Set the size of the buff ring used by the transmit side of the stack, we have found that it is necessary to have it quite large in order to get UDP to perform well. hw.ixlv.dynamic_rx_itr The dynamic RX interrupt control, set to 1 to enable, off by default. hw.ixlv.dynamic_tx_itr The dynamic TX interrupt control, set to 1 to enable, off by default. hw.ixlv.rx_itr The RX interrupt rate value, set to 8K by default. hw.ixlv.tx_itr The TX interrupt rate value, set to 4K by default.
SUPPORTFor general information and support, go to the Intel support website at: http://support.intel.com/. If an issue is identified with this driver with a supported adapter, email all the specific information related to the issue to ⟨@intel.com⟩.
SEE ALSOarp(4), ixl(4), netintro(4), ng_ether(4), vlan(4), ifconfig(8)
HISTORYThe ixlv device driver first appeared in FreeBSD 10.1.
AUTHORSThe ixlv driver was written by Jack Vogel <@FreeBSD.org> and Eric Joyner <@gmail.com>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | ixl(4freebsd) | ixlv(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | vlan(4freebsd)|