IF_KUE(4FREEBSD) - Linux man page online | Special files
Kawasaki LSI KL5KUSB101B USB Ethernet driver.
November 24, 2015
KUE(4) BSD Kernel Interfaces Manual KUE(4)
BSD November 24, 2015 BSD
NAMEkue — Kawasaki LSI KL5KUSB101B USB Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device uhci device ohci device usb device miibus device uether device kue Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_kue_load="YES"
DESCRIPTIONThe kue driver provides support for USB Ethernet adapters based on the Kawasaki LSI KL5KLUSB101B chipset. The KL5KLUSB101B supports a 128-entry multicast filter, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The Kawasaki chipset supports only 10Mbps half-duplex mode, hence there are no ifmedia(4) modes to select. For more information on configuring this device, see ifconfig(8).
HARDWAREThe kue driver supports Kawasaki LSI KL5KLUSB101B based USB Ethernet adapters including: · 3Com 3c19250 · 3Com 3c460 HomeConnect Ethernet USB Adapter · ADS Technologies USB-10BT · AOX USB101 · ATen UC10T · Abocom URE 450 · Corega USB-T · D-Link DSB-650C · Entrega NET-USB-E45, NET-HUB-3U1E · I/O Data USB ETT · Kawasaki DU-H3E · LinkSys USB10T · Netgear EA101 · Peracom USB Ethernet Adapter · Psion Gold Port USB Ethernet adapter · SMC 2102USB, 2104USB
DIAGNOSTICSkue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. kue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
SEE ALSOarp(4), netintro(4), ng_ether(4), ifconfig(8)
HISTORYThe kue device driver first appeared in FreeBSD 4.0.
AUTHORSThe kue driver was written by Bill Paul <@ee.columbia.edu>.
BUGSThe kue driver does not accumulate Ethernet collisions statistics because the Kawasaki firmware does not appear to maintain any internal statistics.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | kue(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd)|