IF_TL(4FREEBSD) - man page online | special files
Texas Instruments ThunderLAN Ethernet device driver.
July 16, 2005
TL(4) BSD Kernel Interfaces Manual TL(4)
NAMEtl — Texas Instruments ThunderLAN Ethernet device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device tl Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_tl_load="YES"
DESCRIPTIONThe tl driver provides support for PCI Ethernet adapters based on the Texas Instruments ThunderLAN Ethernet controller chip. The ThunderLAN controller has a standard MII interface that supports up to 32 physical interface devices (PHYs). It also has a built-in 10baseT PHY hardwired at MII address 31, which may be used in some 10Mbps-only hardware configurations. In 100Mbps configurations, a National Semiconductor DP83840A or other MII-compliant PHY may be attached to the Thunder‐ LAN's MII bus. If a DP83840A or equivalent is available, the ThunderLAN chip can operate at either 100Mbps or 10Mbps in either half-duplex or full-duplex modes. The ThunderLAN's built-in PHY and the DP83840A also support autonegotiation. The tl driver supports the following media types: autoselect Enable autoselection of the media type and options. Note that this option is only available on those PHYs that support autonegotiation. Also, the PHY will not advertise those modes that have been explicitly disabled using the following media options. 10baseT/UTP Set 10Mbps operation. 100baseTX Set 100Mbps (Fast Ethernet) operation. 10base5/AUI Enable AUI/BNC interface (useful only with the built-in PHY). The tl driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. hw-loopback Enable hardware loopback mode. Note that the 100baseTX media type is only available if supported by the PHY. For more information on configuring this device, see ifconfig(8).
HARDWAREThe tl driver supports Texas Instruments ThunderLAN based Ethernet and Fast Ethernet adapters including a large number of Compaq PCI Ethernet adapters. Also supported are: · Olicom OC-2135/2138 10/100 TX UTP adapter · Olicom OC-2325/OC-2326 10/100 TX UTP adapter · Racore 8148 10baseT/100baseTX/100baseFX adapter · Racore 8165 10/100baseTX adapter The tl driver also supports the built-in Ethernet adapters of various Compaq Prosignia servers and Compaq Deskpro desktop machines including: · Compaq Netelligent 10 · Compaq Netelligent 10 T PCI UTP/Coax · Compaq Netelligent 10/100 · Compaq Netelligent 10/100 Dual-Port · Compaq Netelligent 10/100 Proliant · Compaq Netelligent 10/100 TX Embedded UTP · Compaq Netelligent 10/100 TX UTP · Compaq NetFlex 3P · Compaq NetFlex 3P Integrated · Compaq NetFlex 3P w/BNC
DIAGNOSTICStl%d: couldn't map memory A fatal initialization error has occurred. tl%d: couldn't map interrupt A fatal initialization error has occurred. tl%d: device timeout The device has stopped responding to the network, or there is a prob‐ lem with the network connection (cable). tl%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring. tl%d: no memory for tx list The driver failed to allocate an mbuf for the transmitter ring when allocating a pad buffer or collapsing an mbuf chain into a cluster.
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
HISTORYThe tl device driver first appeared in FreeBSD 2.2.
BSD July 16, 2005 BSD
AUTHORSThe tl driver was written by Bill Paul <@ctr.columbia.edu>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | tl(4freebsd)|