IF_URE(4FREEBSD) - Linux man page online | Special files
RealTek RTL8152 USB to Fast Ethernet controller driver.
December 1, 2015
URE(4) BSD Kernel Interfaces Manual URE(4)
BSD December 1, 2015 BSD
NAMEure — RealTek RTL8152 USB to Fast Ethernet controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device uhci device ohci device usb device miibus device uether device ure Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_ure_load="YES"
DESCRIPTIONThe ure driver provides support for USB Ethernet adapters based on the RealTek RTL8152 USB to Fast Ethernet controller chip. The RTL8152 contains an integrated Fast Ethernet MAC, which supports both 10 and 100Mbps speeds in either full or half duplex. The ure driver supports the following media types: autoselect Enable auto selection of the media type and options. The user can manually override the auto selected mode by adding media options to the /etc/rc.conf file. 10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The ure driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
DIAGNOSTICSure%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired.
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
AUTHORSThe ure driver was written by Kevin Lo <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | ure(4freebsd)|