IF_VTNET(4FREEBSD) - Linux man page online | Special files
VirtIO Ethernet driver.
January 22, 2012
VTNET(4) BSD Kernel Interfaces Manual VTNET(4)
BSD January 22, 2012 BSD
NAMEvtnet — VirtIO Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device vtnet Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_vtnet_load="YES"
DESCRIPTIONThe vtnet device driver provides support for VirtIO Ethernet devices. If the hypervisor advertises the appreciate features, the vtnet driver supports TCP/UDP checksum offload for both transmit and receive, TCP segmentation offload (TSO), TCP large receive offload (LRO), hardware VLAN tag stripping/insertion features, a multicast hash fil‐ ter, as well as Jumbo Frames (up to 9216 bytes), which can be configured via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility config‐ ures the adapter to receive and transmit Jumbo Frames. For more information on configuring this device, see ifconfig(8).
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5). hw.vtnet.csum_disable hw.vtnet.X.csum_disable This tunable disables receive and send checksum offload. The default value is 0. hw.vtnet.tso_disable hw.vtnet.X.tso_disable This tunable disables TSO. The default value is 0. hw.vtnet.lro_disable hw.vtnet.X.lro_disable This tunable disables LRO. The default value is 0. hw.vtnet.mq_disable hw.vtnet.X.mq_disable This tunable disables multiqueue. The default value is 0. hw.vtnet.mq_max_pairs hw.vtnet.X.mq_max_pairs This tunable sets the maximum number of transmit and receive queue pairs. Multiple queues are only supported when the Multiqueue feature is negotiated. This driver supports a maximum of 8 queue pairs. The number of queue pairs used is the lesser of the maximum supported by the driver and the hypervisor, the number of CPUs present in the guest, and this tunable if not zero. The default value is 0.
SEE ALSOarp(4), netintro(4), ng_ether(4), virtio(4), vlan(4), ifconfig(8)
HISTORYThe vtnet driver was written by Bryan Venteicher <@FreeBSD.org>. It first appeared in FreeBSD 9.0.
CAVEATSThe vtnet driver only supports LRO when the hypervisor advertises the mergeable buffer fea‐ ture.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd) | virtio(4freebsd) | vlan(4freebsd) | vtnet(4freebsd)|