IF_VXGE(4FREEBSD) - man page online | special files
Neterion X3100 10GbE Server/Storage adapter driver.
March 16, 2011
VXGE(4) BSD Kernel Interfaces Manual VXGE(4)
NAMEvxge — Neterion X3100 10GbE Server/Storage adapter driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device vxge Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_vxge_load="YES"
DESCRIPTIONThe vxge driver provides support for Neterion X3100 adapters. The driver supports TCP Seg‐ mentation Offload (TSO/LSO), Large Receive Offload (LRO), Jumbo Frames, Receive Traffic Hash (RTH), VLAN, Promiscuous mode and Multi function mode. The vxge driver supports the following function modes: SF1_VP17 - 1 function with 17 VPATHs MF8_VP2 - 8 functions with 2 VPATHs per function MF2_VP8 - 2 functions, 8 Paths/Function MF4_VP4 - 4 Functions, 4 Paths/Function MF8P_VP2 - 8 functions with 2 VPATHs per function required for DirectIO For general information and support, please visit the Neterion support page http://www.neterion.com/support/support.html. Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to transmit and receive Jumbo Frames. X3100 adapters support Jumbo Frames up to 9600 bytes. For Jumbo Frames, the driver will try to allocate physically contiguous buffers. Failures to do so may degrade the performance. To resolve such problems, please visit http://www.neterion.com where additional information and a kernel patch can be found. For more information on configuring this device, see ifconfig(8).
HARDWAREThe vxge driver supports Neterion X3100 10 Gigabit Ethernet adapters listed in http://www.neterion.com.
SUPPORTFor troubleshooting tips and FAQs, please visit http://trac.neterion.com/cgi-bin/trac.cgi/wiki/TitleIndex?anonymous. For any issues please send an email to ⟨@neterion.com⟩.
SEE ALSOarp(8), ifconfig(8)
BSD March 16, 2011 BSD
AUTHORSThe vxge driver was written by Neterion ⟨@neterion.com⟩.
|This manual||Reference||Other manuals|
|refer to||arp(8) | ifconfig(8) | vxge(4freebsd)|