IF_WPI(4FREEBSD) - man page online | special files
Intel 3945ABG Wireless LAN IEEE 802.11 driver.
October 5, 2008
WPI(4) BSD Kernel Interfaces Manual WPI(4)
NAMEwpi — Intel 3945ABG Wireless LAN IEEE 802.11 driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device wpi device wpifw device pci device wlan device wlan_amrr device firmware Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_wpi_load="YES"
DESCRIPTIONThe wpi driver provides support for the Intel 3945ABG Wireless network adapter. wpi sup‐ ports station, adhoc, and monitor mode operation. Only one virtual interface may be config‐ ured at any time. For more information on configuring this device, see ifconfig(8). This driver requires the firmware built with the wpifw module to work.
FILES/usr/share/doc/legal/intel_wpi/LICENSE wpi firmware license
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan0 create wlandev wpi0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan0 create wlandev wpi0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan0 create wlandev wpi0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up Join a specific BSS network with 128-bit WEP encryption: ifconfig wlan0 create wlandev wpi0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
DIAGNOSTICSwpi%d: could not load firmware image '%s' The driver failed to load the firmware image using the firmware(9) subsystem. Verify the wpifw firmware module is installed. wpi%d: fatal firmware error An unknown error has occurred in the uploaded firmware, you may have to unload/reload the driver to continue. wpi%d: Radio transmitter is switched off The hardware switch controlling the radio is cur‐ rently turned off. Data transmission is not possible in this state.
SEE ALSOwpifw(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
AUTHORSThe original wpi driver was written for OpenBSD by Damien Bergamini <@free.fr>. Benjamin Close <@FreeBSD.org> ported wpi to FreeBSD.
BSD October 5, 2008 BSD
BUGSNot all the error messages are documented here. Background scanning is not currently supported.
|This manual||Reference||Other manuals|
|refer to||firmware(9freebsd) | ifconfig(8) | pci(4freebsd) | wlan(4freebsd) | wlan_ccmp(4freebsd) | wlan_tkip(4freebsd) | wlan_wep(4freebsd) | wpa_supplicant(8) | wpi(4freebsd)|