IF_XE(4FREEBSD) - Linux man page online | Special files
Xircom PCMCIA Ethernet device driver.
July 16, 2005
XE(4) BSD Kernel Interfaces Manual XE(4)
BSD July 16, 2005 BSD
NAMExe — Xircom PCMCIA Ethernet device driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device xe Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_xe_load="YES"
DESCRIPTIONThe xe driver supports PCMCIA Ethernet adapters based on Xircom CE2- and CE3-class hardware. This includes devices made by Xircom along with various OEM manufacturers. Please note that the xe driver only supports PCMCIA cards and their Ethernet functions. xe does not support the on-board modem device located on some version of the Ethernet/modem combo cards. In particular, Xircom RealPort2 cards are not supported by this driver. The xe driver supports the following media types: autoselect Enable autoselection of media type and options. 10Base2/BNC Select 10Mbps operation on a BNC coaxial connector. 10BaseT/UTP Select 10Mbps operation on a RJ-45 connector. 100BaseTX Select 100Mbps operation. Note that 100BaseTX operation is not available on CE2-class cards, while the 10Base2/BNC mode is only available on CE2-class cards. Full-duplex operation is currently not sup‐ ported. For more information on configuring network interface devices, see ifconfig(8).
HARDWAREThe xe driver supports the following cards: · Xircom CreditCard Ethernet (PS-CE2-10) · Xircom CreditCard Ethernet + Modem 28 (PS-CEM-28) · Xircom CreditCard Ethernet + Modem 33 (CEM33) · Xircom CreditCard 10/100 (CE3, CE3B) · Xircom CreditCard Ethernet 10/100 + Modem 56 (CEM56) · Xircom RealPort Ethernet 10 (RE10) · Xircom RealPort Ethernet 10/100 (RE100) · Xircom RealPort Ethernet 10/100 + Modem 56 (REM56, REM56G) · Accton Fast EtherCard-16 (EN2226) · Compaq Microcom CPQ550 Ethernet/Modem PC Card · Compaq Netelligent 10/100 PC Card (CPQ-10/100) · Intel EtherExpress Pro/100 PC Card Mobile Adapter 16 (Pro/100 M16A) · Intel EtherExpress Pro/100 LAN/Modem PC Card Adapter (Pro/100 M16B) Other similar devices using the same hardware may also be supported.
DIAGNOSTICSxe%d: Cannot allocate ioport xe%d: Cannot allocate irq A fatal initialization error occurred while attempting to allo‐ cate system resources for the card. xe%d: Unable to fix your %s combo card A fatal initialization error occurred while attempt‐ ing to attach an Ethernet/modem combo card. xe%d: watchdog timeout: resetting card The card failed to generate an interrupt acknowledg‐ ing a transmitted packet. May indicate a PCMCIA configuration problem. xe%d: no carrier The card has lost all contact with the network; this usually indicates a cable problem.
SEE ALSOpccard(4), ifconfig(8)
HISTORYThe xe driver first appeared in FreeBSD 3.3.
AUTHORSThe xe device driver was written by Scott Mitchell <@FreeBSD.org>. This manual page was written by Scott Mitchell <@FreeBSD.org>, and Tom Rhodes <@FreeBSD.org>.
BUGSSupported devices will fail to attach on some machines using the NEWCARD PC Card framework. Automatic media selection is usually unreliable.
|This manual||Reference||Other manuals|
|refer to||ifconfig(8) | pccard(4freebsd) | xe(4freebsd)|