IGMP(4FREEBSD) - Linux man page online | Special files
Internet Group Management Protocol.
March 9, 2009
IGMP(4) BSD Kernel Interfaces Manual IGMP(4)
BSD March 9, 2009 BSD
NAMEigmp — Internet Group Management Protocol
SYNOPSIS#include <sys/types.h> #include <sys/socket.h> #include <netinet/in.h> #include <netinet/in_systm.h> #include <netinet/ip.h> #include <netinet/igmp.h> int socket(AF_INET, SOCK_RAW, IPPROTO_IGMP);
DESCRIPTIONIGMP is a control plane protocol used by IPv4 hosts and routers to propagate multicast group membership information. Normally this protocol is not used directly, except by the kernel itself, in response to multicast membership requests by user applications. Routing proto‐ cols may open a raw socket to directly interact with igmp. As of FreeBSD 8.0, IGMP version 3 is implemented. This adds support for Source-Specific Multicast (SSM), whereby applications may communicate to upstream multicast routers that they are only interested in receiving multicast streams from particular sources.
SYSCTL VARIABLESnet.inet.igmp.stats This opaque read-only variable exposes the stack-wide IGMPv3 protocol statistics to netstat(1). net.inet.igmp.ifinfo This opaque read-only variable exposes the per-link IGMPv3 status to ifmcstat(8). net.inet.igmp.gsrdelay This variable specifies the time threshold, in seconds, for processing Group-and- Source Specific Queries (GSR). As GSR query processing requires maintaining state on the host, it may cause memory to be allocated, and is therefore a potential attack point for Denial-of-Service (DoS). If more than one GSR query is received within this threshold, it will be dropped, to mitigate the potential for DoS. net.inet.igmp.default_version This variable controls the default version of IGMP to be used on all links. This sysctl is normally set to 3 by default. net.inet.igmp.legacysupp If this variable is non-zero, then IGMP v1 and v2 membership reports received on a link will be allowed to suppress the IGMP v3 state-change reports which would other‐ wise be issued by this host. This sysctl is normally enabled by default. net.inet.igmp.v2enable If this variable is non-zero, then IGMP v2 membership queries will be processed by this host, and backwards compatibility will be enabled until the v2 'Old Querier Present' timer expires. This sysctl is normally enabled by default. net.inet.igmp.v1enable If this variable is non-zero, then IGMP v1 membership queries will be processed by this host, and backwards compatibility will be enabled until the v1 'Old Querier Present' timer expires. This sysctl is normally enabled by default. net.inet.igmp.sendlocal If this variable is non-zero, then IGMP state-changes for groups in the 126.96.36.199/24 link-scope prefix will be issued. This behaviour is recommended if deploying FreeBSD in a network environment with layer 2 devices which snoop IGMP traffic to mitigate multicast propagation throughout the network. This sysctl is normally enabled by default. net.inet.igmp.sendra If this variable is non-zero, then IGMP v2 and v3 reports will contain the IP Router Alert option. This sysctl is normally enabled by default. net.inet.igmp.recvifkludge If this variable is non-zero, then received IGMP reports which contain 0.0.0.0 as their source will be rewritten to contain the subnet address. This is useful when there are hosts on-link which have not yet been configured with a primary IPv4 address. This sysctl is normally enabled by default.
SEE ALSOnetstat(1), sourcefilter(3), inet(4), multicast(4), ifmcstat(8)
HISTORYThe igmp manual page re-appeared in FreeBSD 8.0.
|This manual||Reference||Other manuals|
|igmp(4freebsd)||referred by||ip(4freebsd) | multicast(4freebsd) | rawip(4freebsd)|
|refer to||inet(4freebsd) | multicast(4freebsd)|